• Ian

    For those who are having trouble with the Bluetooth interface, here is how I fixed this on Fedora 25 (this will probably work for Ubuntu and other distributions too).

    1. As root, edit /usr/lib/systemd/system/bluetooth.service

    Change the line:
    ExecStart=/usr/libexec/bluetooth/bluetoothd
    to
    ExecStart=/usr/libexec/bluetooth/bluetoothd -C

    2. Change the permissions for /var/run/sdp

    sudo chgrp mygroup /var/run/sdp (where "mygroup" is your username)

    Go to http://localhost:9510/web/ in your web browser and restart the server to make sure this works.

    3. Make SDP permissions permanent each time you boot.

    First, disable or delete the standard startup script that runs when you log in (in Gnome 3, you can use the Gnome Tweak Tool to do this).

    Next, create a replacement startup shell script to run at login (WARNING: do not store your sudo password in this script if you are concerned about having your password stolen. See the reference below for other secure solutions):

    .......................................................................................................................

    #!/bin/bash

    echo YOUR_SUDO_PASSWORD | sudo -S chgrp mygroup /var/run/sdp

    /opt/urserver/urserver-start --no-manager --no-notify &

    exit

    .......................................................................................................................

    Save this file as a .sh file (example: /home/myusername/.unified-remote-bluetooth-startup.sh).

    Now make the script executable (in Gnome 3, right click on the file and find this option under the permissions tab).

    Finally, add this script your startup list so it runs when you log in (in Gnome 3, you can use MenuLibre to create a shortcut to this script. Then you can use the Gnome Tweak Tool to add this shortcut to the startup list).

    References:
    http://unix.stackexchange.com/questions/266349/use-unified-remote-on-fedora-over-bluetooth

    http://askubuntu.com/questions/155791/how-do-i-sudo-a-command-in-a-script-without-being-asked-for-a-password

    posted in Server read more
  • Ian

    I am also having the same problem with Fedora 25. As everyone else is saying, it's probably Wayland. For now at least my keyboard is working for presentations, but not having a mouse is annoying.

    posted in Server read more

Internal error.

Oops! Looks like something went wrong!